What’s Vulnerable › Vulnerabilities
CVE-2025-65099: Claude Code vulnerable to command execution prior to startup trust dialog
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-19 · updated 2026-10-18
- Weakness: CWE-94
Description
Claude Code is an agentic coding tool. Prior to version 1.0.39, when running on a machine with Yarn 3.0 or above, Claude Code could have been tricked to execute code contained in a project via yarn plugins before the user accepted the startup trust dialog. Exploiting this would have required a user to start Claude Code in an untrusted directory and to be using Yarn 3.0 or above. This issue has been patched in version 1.0.39.
Affected products
- anthropics claude-code: before 1.0.39 — fixed in 1.0.39
How to fix
Upgrade to a fixed version: anthropics claude-code 1.0.39. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-65099 or the next vulnerability affects your stack