What’s Vulnerable › Vulnerabilities
CVE-2025-65102: PJSIP is vulnerable to buffer overflow in Opus PLC
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-21 · updated 2026-10-18
- Weakness: CWE-120
Description
PJSIP is a free and open source multimedia communication library. Prior to version 2.16, Opus PLC may zero-fill the input frame as long as the decoder ptime, while the input frame length, which is based on stream ptime, may be less than that. This issue affects PJSIP users who use the Opus audio codec in receiving direction. The vulnerability can lead to unexpected application termination due to a memory overwrite. This issue has been patched in version 2.16.
Affected products
- pjsip pjproject: before 2.16
References
- https://github.com/pjsip/pjproject/commit/6e9bd2e7d25bba26f852771b40693f45da14fa8f
- https://github.com/pjsip/pjproject/security/advisories/GHSA-w5vr-39x7-h8g5
Get alerted when CVE-2025-65102 or the next vulnerability affects your stack