What’s Vulnerable › Vulnerabilities
CVE-2025-65105: Apptainer ineffective application of selinux and apparmor --security options
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-02 · updated 2026-10-18
- Weakness: CWE-61
Description
Apptainer is an open source container platform. In Apptainer versions less than 1.4.5, a container can disable two of the forms of the little used --security option, in particular the forms --security=apparmor:<profile> and --security=selinux:<label> which otherwise put restrictions on operations that containers can do. The --security option has always been mentioned in Apptainer documentation as being a feature for the root user, although these forms do also work for unprivileged users on systems where the corresponding feature is enabled. Apparmor is enabled by default on Debian-based distributions and SElinux is enabled by default on RHEL-based distributions, but on SUSE it depends on the distribution version. This vulnerability is fixed in 1.4.5.
Affected products
- apptainer: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: apptainer 1.4.5. Check the vendor advisory for mitigations.
References
- https://github.com/apptainer/apptainer/commit/4313b42717e18a4add7dd7503528bc15af905981
- https://github.com/apptainer/apptainer/commit/82f17900a0c31bc769bf9b4612d271c7068d8bf2
- https://github.com/apptainer/apptainer/pull/3226
- https://github.com/apptainer/apptainer/security/advisories/GHSA-j3rw-fx6g-q46j
- https://github.com/opencontainers/runc/security/advisories/GHSA-cgrx-mc8f-2prm
- https://github.com/sylabs/singularity/security/advisories/GHSA-wwrx-w7c9-rf87
Get alerted when CVE-2025-65105 or the next vulnerability affects your stack