What’s Vulnerable › Vulnerabilities
CVE-2025-65106: LangChain Vulnerable to Template Injection via Attribute Access in Prompt Templates
- Severity: high (CVSS 8.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-21 · updated 2026-10-19
- Weakness: CWE-1336
Description
LangChain is a framework for building agents and LLM-powered applications. From versions 0.3.79 and prior and 1.0.0 to 1.0.6, a template injection vulnerability exists in LangChain's prompt template system that allows attackers to access Python object internals through template syntax. This vulnerability affects applications that accept untrusted template strings (not just template variables) in ChatPromptTemplate and related prompt template classes. This issue has been patched in versions 0.3.80 and 1.0.7.
Affected products
- langchain-ai langchain: from 1.0.0, < 1.0.7; before 0.3.80
References
- https://github.com/langchain-ai/langchain/commit/c4b6ba254e1a49ed91f2e268e6484011c540542a
- https://github.com/langchain-ai/langchain/commit/fa7789d6c21222b85211755d822ef698d3b34e00
- https://github.com/langchain-ai/langchain/security/advisories/GHSA-6qv9-48xg-fc7f
Get alerted when CVE-2025-65106 or the next vulnerability affects your stack