What’s Vulnerable › Vulnerabilities
CVE-2025-65107: Langfuse SSO Account Takeover via CSRF or phishing attack
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-21 · updated 2026-10-19
- Weakness: CWE-285
Description
Langfuse is an open source large language model engineering platform. In versions from 2.95.0 to before 2.95.12 and from 3.17.0 to before 3.131.0, in SSO provider configurations without an explicit AUTH_<PROVIDER>_CHECK setting, a potential account takeover may happen if an authenticated user is made to call a specifically crafted URL via a CSRF or phishing attack. This issue has been patched in versions 2.95.12 and 3.131.0. A workaround for this issue involves setting AUTH_<PROVIDER>_CHECK.
Affected products
- langfuse: from 2.95.0 before 2.95.12; from 3.17.0 before 3.131.0 — fixed in 2.95.12, 3.131.0
How to fix
Upgrade to a fixed version: langfuse 2.95.12, 3.131.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-65107 or the next vulnerability affects your stack