What’s Vulnerable › Vulnerabilities
CVE-2025-65112: PubNet Critical Authentication Bypass Allows Unauthenticated Package Upload and Identity Spoofing
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-29 · updated 2026-10-07
- Weakness: CWE-306
Description
PubNet is a self-hosted Dart & Flutter package service. Prior to version 1.1.3, the /api/storage/upload endpoint in PubNet allows unauthenticated users to upload packages as any user by providing arbitrary author-id values. This enables identity spoofing, privilege escalation, and supply chain attacks. This issue has been patched in version 1.1.3.
Affected products
- ricardoboss PubNet: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: ricardoboss PubNet 1.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/ricardoboss/PubNet/security/advisories/GHSA-pg82-fqrg-q6j5
- https://github.com/ricardoboss/PubNet/security/advisories/GHSA-pg82-fqrg-q6j5
Get alerted when CVE-2025-65112 or the next vulnerability affects your stack