What’s Vulnerable › Vulnerabilities
CVE-2025-65187
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-02 · updated 2026-06-17
- Weakness: CWE-79
Description
A Stored Cross Site Scripting vulnerability exists in CiviCRM before v6.7 in the Accounting Batches field. An authenticated user can inject malicious JavaScript into this field and it executes whenever the page is viewed.
Affected products
- CiviCRM: before 6.7.0 — fixed in 6.7.0
How to fix
Upgrade to a fixed version: CiviCRM 6.7.0. Check the vendor advisory for mitigations.
References
- https://civicrm.com/
- https://github.com/lukehebe/Vulnerability-Disclosures/blob/main/CVE-2025-65187.pdf
Get alerted when CVE-2025-65187 or the next vulnerability affects your stack