What’s Vulnerable › Vulnerabilities
CVE-2025-65199: Windscribe for Linux 'changeMTU' local privilege escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-10 · updated 2026-09-28
- Weakness: CWE-78
Description
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.
Affected products
- Windscribe: from 2.10.1 through 2.17.10; 2.18.1-alpha, 2.18.3, 2.18.5
References
- https://github.com/Windscribe/Desktop-App
- https://github.com/Windscribe/Desktop-App/compare/v2.18.2...v2.18.3?diff=unified&w#diff-57e27ab201a1a612609087b839e03bf87a5a063ffcc3f465a6245469bc102754
- https://github.com/Windscribe/Desktop-App/compare/v2.18.2...v2.18.3?diff=unified&w#diff-cfc5df17057ed92112ae70a42c81c57c79f434429210ff881fb0771cf8e39b4c
- https://hackingbydoing.wixsite.com/hackingbydoing/post/windscribe-vpn-local-privilege-escalation
- https://raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/IT/white/2025/va-25-343-01.json
- https://www.cve.org/CVERecord?id=CVE-2025-65199
Get alerted when CVE-2025-65199 or the next vulnerability affects your stack