What’s Vulnerable › Vulnerabilities
CVE-2025-65212
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-01-06 · updated 2026-06-17
- Weakness: CWE-565
Description
An issue was discovered in NJHYST HY511 POE core before 2.1 and plugins before 0.1. The vulnerability stems from the device's insufficient cookie verification, allowing an attacker to directly request the configuration file address and download the core configuration file without logging into the device management backend. By reading the corresponding username and self-decrypted MD5 password in the core configuration file, the attacker can directly log in to the backend, thereby bypassing the front-end backend login page.
Affected products
- Njhyst Hy511 Firmware: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: Njhyst Hy511 Firmware 2.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/a2148001284/bcdda75fc8718454f16a7b9259463719
- https://github.com/a2148001284/test1/blob/main/%E6%9C%AA%E6%8E%88%E6%9D%83%E8%AE%BF%E9%97%AE%E5%90%8E%E5%8F%B0%E6%BC%8F%E6%B4%9EEN.md
Get alerted when CVE-2025-65212 or the next vulnerability affects your stack