What’s Vulnerable › Vulnerabilities
CVE-2025-6523
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-22 · updated 2026-06-17
- Weakness: CWE-1391
Description
Use of weak credentials in emergency authentication component in Devolutions Server allows an unauthenticated attacker to bypass authentication via brute forcing the short emergency codes generated by the server within a feasible timeframe. This issue affects the following versions : * Devolutions Server 2025.2.2.0 through 2025.2.3.0 * Devolutions Server 2025.1.11.0 and earlier
Affected products
- Devolutions Server: through 2025.1.11.0; from 2025.2.2.0 before 2025.2.4.0 — fixed in 2025.2.4.0
How to fix
Upgrade to a fixed version: Devolutions Server 2025.2.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6523 or the next vulnerability affects your stack