What’s Vulnerable › Vulnerabilities
CVE-2025-6543: Memory overflow vulnerability leading to unintended control flow and Denial of Service
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-06-30
- EPSS: 10.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-119
Description
Memory overflow vulnerability leading to unintended control flow and Denial of Service in NetScaler ADC and NetScaler Gateway when configured as Gateway (VPN virtual server, ICA Proxy, CVPN, RDP Proxy) OR AAA virtual server
Summary
CVE-2025-6543 is a critical buffer overflow (CVSS 9.8) in Citrix NetScaler ADC and NetScaler Gateway that can cause unintended control flow and denial of service. It affects appliances configured as a Gateway (VPN virtual server, ICA Proxy, CVPN, RDP Proxy) or as an AAA virtual server. The flaw is listed in CISA's Known Exploited Vulnerabilities catalog with active exploitation, and EPSS estimates a 10.4% chance of exploitation in 30 days. Apply the vendor fixes: NetScaler ADC 13.1-37.236, 13.1-59.19, or 14.1-47.46; NetScaler Gateway 13.1-59.19 or 14.1-47.46. If patching is not possible, follow vendor mitigation instructions, apply BOD 22-01 guidance for cloud services, or discontinue use of the product.
تُعدّ CVE-2025-6543 ثغرة تجاوز سعة المخزن المؤقت (buffer overflow) حرجة بدرجة CVSS 9.8 في Citrix NetScaler ADC وNetScaler Gateway، وقد تؤدي إلى تدفق تحكم غير مقصود وانقطاع الخدمة (Denial of Service). تتأثر الأجهزة المهيأة كـ Gateway (خادم VPN افتراضي، أو ICA Proxy، أو CVPN، أو RDP Proxy) أو كخادم AAA افتراضي. الثغرة مدرجة في كتالوج CISA للثغرات المعروفة باستغلالها مع استغلال نشط، وتقدّر EPSS احتمال استغلالها خلال 30 يوماً بنسبة 10.4%. طبّق إصدارات الإصلاح من المورّد: NetScaler ADC 13.1-37.236 أو 13.1-59.19 أو 14.1-47.46، وNetScaler Gateway 13.1-59.19 أو 14.1-47.46. وإذا تعذّر الترقيع، فاتبع تعليمات التخفيف من المورّد، أو طبّق إرشادات BOD 22-01 للخدمات السحابية، أو أوقف استخدام المنتج.
Affected products
- Citrix NetScaler ADC: from 13.1 before 13.1-59.19; from 14.1 before 14.1-47.46 — fixed in 13.1-59.19, 14.1-47.46
- Citrix Netscaler Application Delivery Controller Fips: from 13.1 before 13.1-37.236 — fixed in 13.1-37.236
- Citrix Netscaler Application Delivery Controller Ndcpp: from 13.1 before 13.1-37.236 — fixed in 13.1-37.236
- Citrix NetScaler Gateway: from 13.1 before 13.1-59.19; from 14.1 before 14.1-47.46 — fixed in 13.1-59.19, 14.1-47.46
- NetScaler ADC: from 14.1 before 47.46; from 13.1 before 59.19; from 13.1 FIPS and NDcPP before 37.236 — fixed in 47.46, 59.19, 37.236
- NetScaler Gateway: from 14.1 before 47.46; from 13.1 before 59.19; from 13.1 FIPS and NDcPP before 37.236 — fixed in 47.46, 59.19, 37.236
How to fix
Upgrade to a fixed version: Citrix NetScaler ADC 13.1-59.19, 14.1-47.46; Citrix Netscaler Application Delivery Controller Fips 13.1-37.236; Citrix Netscaler Application Delivery Controller Ndcpp 13.1-37.236; Citrix NetScaler Gateway 13.1-59.19, 14.1-47.46; NetScaler ADC 47.46, 59.19, 37.236; NetScaler Gateway 47.46, 59.19, 37.236. Check the vendor advisory for mitigations.
References
- https://support.citrix.com/support-home/kbsearch/article?articleNumber=CTX694788
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-6543
Get alerted when CVE-2025-6543 or the next vulnerability affects your stack