What’s Vulnerable › Vulnerabilities
CVE-2025-65431
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-15 · updated 2026-10-14
- Weakness: CWE-287
Description
An issue was discovered in allauth-django before 65.13.0. Both Okta and NetIQ were using preferred_username as the identifier for third-party provider accounts. That value may be mutable and should therefore be avoided for authorization decisions. The providers are now using sub instead.
Affected products
- allauth django-allauth: before 65.13.0 — fixed in 65.13.0
How to fix
Upgrade to a fixed version: allauth django-allauth 65.13.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-65431 or the next vulnerability affects your stack