What’s Vulnerable › Vulnerabilities
CVE-2025-6547: On Node.js < 3, pbkdf2 silently disregards Uint8Array input, returning static keys
- Severity: critical (CVSS 9.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in pbkdf2 allows Signature Spoofing by Improper Validation.This issue affects pbkdf2: <=3.1.2.
Affected products
- Npm Pbkdf2: from 1.0.0 before 3.1.3 — fixed in 3.1.3
How to fix
Upgrade to a fixed version: Npm Pbkdf2 3.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/browserify/pbkdf2/commit/e3102a8cd4830a3ac85cd0dd011cc002fdde33bb
- https://github.com/browserify/pbkdf2/security/advisories/GHSA-v62p-rq8g-8h59
Get alerted when CVE-2025-6547 or the next vulnerability affects your stack