What’s Vulnerable › Vulnerabilities
CVE-2025-65637: Logrus is vulnerable to DoS when using Entry.Writer()
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-04 · updated 2026-06-17
- Weakness: CWE-400
Description
A denial-of-service vulnerability exists in github.com/sirupsen/logrus when using Entry.Writer() to log a single-line payload larger than 64KB without newline characters. Due to limitations in the internal bufio.Scanner, the read fails with "token too long" and the writer pipe is closed, leaving Writer() unusable and causing application unavailability (DoS). This affects versions < 1.8.3, 1.9.0, and 1.9.2. The issue is fixed in 1.8.3, 1.9.1, and 1.9.3+, where the input is chunked and the writer continues to function even if an error is logged.
Affected products
- Turbopuffer Logrus: before 1.8.3; 1.9.0, 1.9.2 — fixed in 1.8.3
- Go Github.Com/Sirupsen/Logrus: before 1.8.3; from 1.9.0 before 1.9.1; from 1.9.2 before 1.9.3 — fixed in 1.8.3, 1.9.1, 1.9.3
How to fix
Upgrade to a fixed version: Turbopuffer Logrus 1.8.3; Go Github.Com/Sirupsen/Logrus 1.8.3, 1.9.1, 1.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/mjuanxd/logrus-dos-poc
- https://github.com/mjuanxd/logrus-dos-poc/blob/main/README.md
- https://github.com/sirupsen/logrus/issues/1370
- https://github.com/sirupsen/logrus/pull/1376
- https://github.com/sirupsen/logrus/releases/tag/v1.8.3
- https://github.com/sirupsen/logrus/releases/tag/v1.9.1
- https://github.com/sirupsen/logrus/releases/tag/v1.9.3
- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMSIRUPSENLOGRUS-5564391
Get alerted when CVE-2025-65637 or the next vulnerability affects your stack