What’s Vulnerable › Vulnerabilities
CVE-2025-65730
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-05 · updated 2026-06-17
- Weakness: CWE-798
Description
Authentication Bypass via Hardcoded Credentials GoAway up to v0.62.18, fixed in 0.62.19, uses a hardcoded secret for signing JWT tokens used for authentication.
Affected products
- Pommee Goaway: before 0.62.19 — fixed in 0.62.19
How to fix
Upgrade to a fixed version: Pommee Goaway 0.62.19. Check the vendor advisory for mitigations.
References
- https://github.com/gian2dchris/CVEs/tree/CVE-2025-65730/CVE-2025-65730
- https://github.com/pommee/goaway/blob/v0.62.18/backend/api/auth.go#L48
- https://github.com/pommee/goaway/blob/v0.62.18/backend/api/middleware.go#L110
- https://github.com/pommee/goaway/blob/v0.62.18/backend/api/middleware.go#L15
- https://github.com/pommee/goaway/blob/v0.62.18/backend/api/middleware.go#L40
- https://github.com/pommee/goaway/blob/v0.62.18/backend/api/middleware.go#L69
- https://github.com/pommee/goaway/blob/v0.62.18/backend/api/middleware.go#L88
- https://github.com/pommee/goaway/commit/5769f8782b7453ca1c22a201b224b5ce48532f64#diff-4ddfd6cf1311ddfd45734bb1dc53bc208df69584ba92ac4f38866bd558434678L15-L40
- https://github.com/pommee/goaway/releases/tag/v0.62.16
Get alerted when CVE-2025-65730 or the next vulnerability affects your stack