What’s Vulnerable › Vulnerabilities
CVE-2025-6574: Service Finder Bookings < 6.1 - Authenticated (Subscriber+) Privilege Escalation via Account Takeover
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-01 · updated 2026-10-18
- Weakness: CWE-639
Description
The Service Finder Bookings plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and excluding, 6.1. This is due to the plugin not properly validating a user's identity prior to updating their details like email. This makes it possible for authenticated attackers, with subscriber-level access and above, to change arbitrary user's email addresses, including administrators, and leverage that to reset the user's password and gain access to their account.
Affected products
- aonetheme Service Finder Bookings: before 6.1 — fixed in 6.1
How to fix
Upgrade to a fixed version: aonetheme Service Finder Bookings 6.1. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/service-finder-service-and-business-listing-wordpress-theme/15208793
- https://www.wordfence.com/threat-intel/vulnerabilities/id/264cb002-bf40-4cc2-9c21-cda9bb24f494?source=cve
Get alerted when CVE-2025-6574 or the next vulnerability affects your stack