What’s Vulnerable › Vulnerabilities
CVE-2025-65741
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-09 · updated 2026-06-17
- Weakness: CWE-427
Description
Sublime Text 3 Build 3208 or prior for MacOS is vulnerable to Dylib Injection. An attacker could compile a .dylib file and force the execution of this library in the context of the Sublime Text application.
Affected products
- Sublimetext Sublime Text 3: before 3.2.2 — fixed in 3.2.2
How to fix
Upgrade to a fixed version: Sublimetext Sublime Text 3 3.2.2. Check the vendor advisory for mitigations.
References
- https://github.com/sublimehq/sublime_text
- https://github.com/vinicius-batistella/CVE-2025-65741/
- https://www.sublimetext.com/3
- https://github.com/vinicius-batistella/CVE-2025-65741/
Get alerted when CVE-2025-65741 or the next vulnerability affects your stack