What’s Vulnerable › Vulnerabilities
CVE-2025-65942: VictoriaMetrics Snappy Decoder DoS Vulnerability is Causing OOM
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-19
- Weakness: CWE-770
Description
VictoriaMetrics is a scalable solution for monitoring and managing time series data. In versions from 1.0.0 to before 1.110.23, from 1.111.0 to before 1.122.8, and from 1.123.0 to before 1.129.1, affected versions are vulnerable to DoS attacks because the snappy decoder ignored VictoriaMetrics request size limits allowing malformed blocks to trigger excessive memory use. This could lead to OOM errors and service instability. The fix enforces block-size checks based on MaxRequest limits. This issue has been patched in versions 1.110.23, 1.122.8, and 1.129.1.
Affected products
- VictoriaMetrics: from 1.0.0, < 1.110.23; from 1.111.0, < 1.122.8; from 1.123.0, < 1.129.1
References
- https://github.com/VictoriaMetrics/VictoriaMetrics/commit/51b44afd34d2c9a392d4ebedeeb5b4a7f5beca24
- https://github.com/VictoriaMetrics/VictoriaMetrics/releases/tag/v1.110.23
- https://github.com/VictoriaMetrics/VictoriaMetrics/releases/tag/v1.122.8
- https://github.com/VictoriaMetrics/VictoriaMetrics/releases/tag/v1.129.1
- https://github.com/VictoriaMetrics/VictoriaMetrics/security/advisories/GHSA-66jq-2c23-2xh5
Get alerted when CVE-2025-65942 or the next vulnerability affects your stack