What’s Vulnerable › Vulnerabilities
CVE-2025-65944: Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`
- Severity: medium (CVSS 5.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-201
Description
Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.
Affected products
- getsentry sentry-javascript: from 10.11.0, < 10.27.0
References
- https://github.com/getsentry/sentry-javascript/commit/a820fa2891fdcf985b834a5b557edf351ec54539
- https://github.com/getsentry/sentry-javascript/pull/17475
- https://github.com/getsentry/sentry-javascript/releases/tag/10.11.0
- https://github.com/getsentry/sentry-javascript/security/advisories/GHSA-6465-jgvq-jhgp
Get alerted when CVE-2025-65944 or the next vulnerability affects your stack