What’s Vulnerable › Vulnerabilities
CVE-2025-65946: Roo Code is Vulnerable to Potential Remote Code Execution via zsh Command Validation Bug
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-21 · updated 2026-10-18
- Weakness: CWE-20
Description
Roo Code is an AI-powered autonomous coding agent that lives in users' editors. Prior to version 3.26.7, Due to an error in validation it was possible for Roo to automatically execute commands that did not match the allow list prefixes. This issue has been patched in version 3.26.7.
Affected products
- RooCodeInc Roo-Code: before 3.26.7 — fixed in 3.26.7
How to fix
Upgrade to a fixed version: RooCodeInc Roo-Code 3.26.7. Check the vendor advisory for mitigations.
References
- https://github.com/RooCodeInc/Roo-Code/commit/b50104cc5987ce64f5154309d967ae8c74cfd1f3
- https://github.com/RooCodeInc/Roo-Code/pull/7667
- https://github.com/RooCodeInc/Roo-Code/security/advisories/GHSA-hwm7-w97p-4h8p
Get alerted when CVE-2025-65946 or the next vulnerability affects your stack