What’s Vulnerable › Vulnerabilities
CVE-2025-65950: WBCE CMS is Vulnerable to Time-Based Blind SQL Injection through groups[] Parameter
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-10 · updated 2026-09-25
- Weakness: CWE-89
Description
WBCE CMS is a content management system. In versions 1.6.4 and below, the user management module allows a low-privileged authenticated user with permissions to modify users to execute arbitrary SQL queries. This can be escalated to a full database compromise, data exfiltration, effectively bypassing all security controls. The vulnerability exists in the admin/users/save.php script, which handles updates to user profiles. The script improperly processes the groups[] parameter sent from the user edit form. This issue is fixed in version 1.6.5.
Affected products
- WBCE CMS: before 1.6.5 — fixed in 1.6.5
How to fix
Upgrade to a fixed version: WBCE CMS 1.6.5. Check the vendor advisory for mitigations.
References
- https://github.com/WBCE/WBCE_CMS/commit/96046178f4c80cf16f7c224054dec7fdadddda7e
- https://github.com/WBCE/WBCE_CMS/releases/tag/1.6.5
- https://github.com/WBCE/WBCE_CMS/security/advisories/GHSA-934v-xhx9-j2f3
Get alerted when CVE-2025-65950 or the next vulnerability affects your stack