What’s Vulnerable › Vulnerabilities

CVE-2025-6596: Vector inserts portlet labels as HTML, allowing for stored XSS through system messages

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Vector. This vulnerability is associated with program files resources/skins.Vector.Js/portlets.Js, resources/skins.Vector.Legacy.Js/portlets.Js. This issue affects Vector: from >= 1.40.0 before 1.42.7, 1.43.2, 1.44.0.

Affected products

How to fix

Upgrade to a fixed version: Wikimedia Foundation Vector 1.43.2, 1.44.0, 1.42.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-6596 or the next vulnerability affects your stack