What’s Vulnerable › Vulnerabilities

CVE-2025-65960: Contao is vulnerable to remote code execution in template closures

Description

Contao is an Open Source CMS. From version 4.0.0 to before 4.13.57, before 5.3.42, and before 5.6.5, back end users with precise control over the contents of template closures can execute arbitrary PHP functions that do not have required parameters. This issue has been patched in versions 4.13.57, 5.3.42, and 5.6.5. A workaround for this issue involves manually patching the Contao\Template::once() method.

Affected products

How to fix

Upgrade to a fixed version: contao 4.13.57, 5.3.42, 5.6.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-65960 or the next vulnerability affects your stack