What’s Vulnerable › Vulnerabilities
CVE-2025-65965: Grype has a credential disclosure vulnerability in Grype JSON output
- Severity: high (CVSS 8.2 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-25 · updated 2026-10-18
- Weakness: CWE-212
Description
Grype is a vulnerability scanner for container images and filesystems. A credential disclosure vulnerability was found in Grype, affecting versions 0.68.0 through 0.104.0. If registry credentials are defined and the output of grype is written using the --file or --output json=<file> option, the registry credentials will be included unsanitized in the output file. This issue has been patched in version 0.104.1. Users running affected versions of grype can work around this vulnerability by redirecting stdout to a file instead of using the --file or --output options.
Affected products
- anchore grype: from 0.68.0, < 0.104.1
References
- https://github.com/anchore/grype/commit/39f7fa17af2739cafe9b27176d4a68f7c05f21c1
- https://github.com/anchore/grype/pull/3068
- https://github.com/anchore/grype/security/advisories/GHSA-6gxw-85q2-q646
Get alerted when CVE-2025-65965 or the next vulnerability affects your stack