What’s Vulnerable › Vulnerabilities
CVE-2025-6597: MediaWiki should not consider autocreation as login for the purposes of security reauthentication
- Severity: none (CVSS 0.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-02-02 · updated 2026-06-17
- Weakness: CWE-22
Description
Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/auth/AuthManager.Php. This issue affects MediaWiki: from * before 1.39.13, 1.42.7, 1.43.2, 1.44.0.
Affected products
- Wikimedia Foundation MediaWiki: before 1.39.13, 1.42.7, 1.43.2, 1.44.0 — fixed in 1.42.7, 1.43.2, 1.44.0, 1.39.13
How to fix
Upgrade to a fixed version: Wikimedia Foundation MediaWiki 1.42.7, 1.43.2, 1.44.0, 1.39.13. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-6597 or the next vulnerability affects your stack