What’s Vulnerable › Vulnerabilities
CVE-2025-66001: NeuVector OpenID Connect is vulnerable to man-in-the-middle (MITM)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-01-08 · updated 2026-10-07
- Weakness: CWE-295
Description
NeuVector supports login authentication through OpenID Connect. However, the TLS verification (which verifies the remote server's authenticity and integrity) for OpenID Connect is not enforced by default. As a result this may expose the system to man-in-the-middle (MITM) attacks.
Affected products
- SUSE neuvector: from 5.3.0 before 5.4.8 — fixed in 5.4.8
How to fix
Upgrade to a fixed version: SUSE neuvector 5.4.8. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-66001
- https://github.com/neuvector/neuvector/security/advisories/GHSA-4jj9-cgqc-x9h5
Get alerted when CVE-2025-66001 or the next vulnerability affects your stack