What’s Vulnerable › Vulnerabilities
CVE-2025-6601: Business Logic Errors in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-27 · updated 2026-10-19
- Weakness: CWE-840
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 18.4 before 18.4.3, and 18.5 before 18.5.1 that under certain conditions could have allowed authenticated users to gain unauthorized project access by exploiting the access request approval workflow.
Affected products
- GitLab: from 18.4.0 before 18.4.3; 18.5.0 — fixed in 18.4.3
How to fix
Upgrade to a fixed version: GitLab 18.4.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2025/10/22/patch-release-gitlab-18-5-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/issues/551267
- https://hackerone.com/reports/3209641
Get alerted when CVE-2025-6601 or the next vulnerability affects your stack