What’s Vulnerable › Vulnerabilities
CVE-2025-66024: XWiki Blog Application home page vulnerable to Stored XSS via Post Title
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-03-04 · updated 2026-08-05
- Weakness: CWE-79
Description
The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.
Affected products
- xwiki-contrib application-blog-ui: before 9.15.7 — fixed in 9.15.7
How to fix
Upgrade to a fixed version: xwiki-contrib application-blog-ui 9.15.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki-contrib/application-blog/commit/cca87f0a0edc2e7e049d46d51f4a4d8f78b714ba
- https://github.com/xwiki-contrib/application-blog/commit/cdcbf2816e9b329e8f006be4391a7ffe80d4bb3f
- https://github.com/xwiki-contrib/application-blog/security/advisories/GHSA-h2xq-h7f9-vh6c
- https://jira.xwiki.org/browse/BLOG-245
Get alerted when CVE-2025-66024 or the next vulnerability affects your stack