What’s Vulnerable › Vulnerabilities
CVE-2025-66030: node-forge ASN.1 OID Integer Truncation
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-26 · updated 2026-10-18
- Weakness: CWE-190
Description
Forge (also called `node-forge`) is a native implementation of Transport Layer Security in JavaScript. An Integer Overflow vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. These arcs may be decoded as smaller, trusted OIDs due to 32-bit bitwise truncation, enabling the bypass of downstream OID-based security decisions. This issue has been patched in version 1.3.2.
Affected products
- digitalbazaar forge: before 1.3.2 — fixed in 1.3.2
- Npm Node-Forge: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: digitalbazaar forge 1.3.2; Npm Node-Forge 1.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/digitalbazaar/forge/commit/3e0c35ace169cfca529a3e547a7848dc7bf57fdb
- https://github.com/digitalbazaar/forge/security/advisories/GHSA-65ch-62r8-g69g
Get alerted when CVE-2025-66030 or the next vulnerability affects your stack