What’s Vulnerable › Vulnerabilities
CVE-2025-66032: Claude Code Command Validation Bypass Allows Arbitrary Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-03 · updated 2026-06-17
- Weakness: CWE-77
Description
Claude Code is an agentic coding tool. Prior to 1.0.93, Due to errors in parsing shell commands related to $IFS and short CLI flags, it was possible to bypass the Claude Code read-only validation and trigger arbitrary code execution. Reliably exploiting this requires the ability to add untrusted content into a Claude Code context window. This vulnerability is fixed in 1.0.93.
Affected products
- anthropics claude-code: before 1.0.93 — fixed in 1.0.93
How to fix
Upgrade to a fixed version: anthropics claude-code 1.0.93. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66032 or the next vulnerability affects your stack