What’s Vulnerable › Vulnerabilities
CVE-2025-66034: fontTools is Vulnerable to Arbitrary File Write and XML injection in fontTools.varLib
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-29 · updated 2026-10-18
- Weakness: CWE-91
Description
fontTools is a library for manipulating fonts, written in Python. In versions from 4.33.0 to before 4.60.2, the fonttools varLib (or python3 -m fontTools.varLib) script has an arbitrary file write vulnerability that leads to remote code execution when a malicious .designspace file is processed. The vulnerability affects the main() code path of fontTools.varLib, used by the fonttools varLib CLI and any code that invokes fontTools.varLib.main(). This issue has been patched in version 4.60.2.
Affected products
- fonttools: from 4.33.0 before 4.60.2 — fixed in 4.60.2
How to fix
Upgrade to a fixed version: fonttools 4.60.2. Check the vendor advisory for mitigations.
References
- https://github.com/fonttools/fonttools/commit/a696d5ba93270d5954f98e7cab5ddca8a02c1e32
- https://github.com/fonttools/fonttools/security/advisories/GHSA-768j-98cg-p3fv
- https://github.com/fonttools/fonttools/security/advisories/GHSA-768j-98cg-p3fv
Get alerted when CVE-2025-66034 or the next vulnerability affects your stack