What’s Vulnerable › Vulnerabilities
CVE-2025-66040: Spotipy has a XSS vulnerability in OAuth callback server
- Severity: low (CVSS 3.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-27 · updated 2026-10-19
- Weakness: CWE-79
Description
Spotipy is a Python library for the Spotify Web API. Prior to version 2.25.2, there is a cross-site scripting (XSS) vulnerability in the OAuth callback server that allows for JavaScript injection through the unsanitized error parameter. Attackers can execute arbitrary JavaScript in the user's browser during OAuth authentication. This issue has been patched in version 2.25.2.
Affected products
- spotipy-dev spotipy: before 2.25.2
References
- https://github.com/spotipy-dev/spotipy/commit/880b92d7243dcf2b83bf31dc365a858d8b5e6767
- https://github.com/spotipy-dev/spotipy/security/advisories/GHSA-r77h-rpp9-w2xm
Get alerted when CVE-2025-66040 or the next vulnerability affects your stack