What’s Vulnerable › Vulnerabilities

CVE-2025-66169: Apache Camel Neo4j: Cypher injection vulnerability in Camel-Neo4j component

Description

Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Camel 4.10.8, 4.14.3, 4.17.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-66169 or the next vulnerability affects your stack