What’s Vulnerable › Vulnerabilities
CVE-2025-66172: Apache CloudStack: Any user can attach a volume in their VMs from backups they should not have access to
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-08 · updated 2026-10-07
- Weakness: CWE-359
Description
The CloudStack Backup plugin has an improper access logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and have access to specific APIs can restore a volume from any other user's backups and attach the volume to their own VMs. Backup plugin users using CloudStack 4.21.0.0+ are recommended to upgrade to CloudStack version 4.22.0.1, which fixes this issue.
Affected products
- Apache Software Foundation Apache CloudStack: from 4.21.0.0 before 4.22.0.1 — fixed in 4.22.0.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CloudStack 4.22.0.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/n8mt5b7wkpysstb8w7rr9f02kc5cq2xm
- http://www.openwall.com/lists/oss-security/2026/05/09/3
Get alerted when CVE-2025-66172 or the next vulnerability affects your stack