What’s Vulnerable › Vulnerabilities
CVE-2025-66178
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-03-10 · updated 2026-10-21
- Weakness: CWE-78
Description
A improper neutralization of special elements used in an os command ('os command injection') vulnerability in Fortinet FortiWeb 8.0.0 through 8.0.2, FortiWeb 7.6.0 through 7.6.6, FortiWeb 7.4.0 through 7.4.11, FortiWeb 7.2.0 through 7.2.12, FortiWeb 7.0.0 through 7.0.12 may allow an authenticated attacked to execute arbitrary commands via a specialy crafted HTTP request.
Affected products
- Fortinet FortiWeb: from 7.0.0 before 7.0.13; from 7.2.0 before 7.2.13; from 7.4.0 before 7.4.12; from 7.6.0 before 7.6.7; from 8.0.0 before 8.0.3 — fixed in 7.0.13, 7.2.13, 7.4.12, 7.6.7, 8.0.3
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 7.0.13, 7.2.13, 7.4.12, 7.6.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66178 or the next vulnerability affects your stack