What’s Vulnerable › Vulnerabilities
CVE-2025-66201: LibreChat is Vulnerable to Server-Side Request Forgery (SSRF) in Actions Capability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-29 · updated 2026-10-07
- Weakness: CWE-20
Description
LibreChat is a ChatGPT clone with additional features. Prior to version 0.8.1-rc2, LibreChat is vulnerable to Server-side Request Forgery (SSRF), by passing specially crafted OpenAPI specs to its "Actions" feature and making the LLM use those actions. It could be used by an authenticated user with access to this feature to access URLs only accessible to the LibreChat server (such as cloud metadata services, through which impersonation of the server might be possible). This issue has been patched in version 0.8.1-rc2.
Affected products
- danny-avila LibreChat: before 0.8.1; 0.8.1, 0.8.1-rc1 — fixed in 0.8.1
How to fix
Upgrade to a fixed version: danny-avila LibreChat 0.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-7m2q-fjwr-5x8v
- https://github.com/danny-avila/LibreChat/security/advisories/GHSA-7m2q-fjwr-5x8v
Get alerted when CVE-2025-66201 or the next vulnerability affects your stack