What’s Vulnerable › Vulnerabilities
CVE-2025-66205: Frappe has the possibility of SQL Injection due to improper validations
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-10-19
- Weakness: CWE-89
Description
Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, a certain endpoint was vulnerable to error-based SQL injection due to lack of validation of parameters. Some information like version could be retrieved. This vulnerability is fixed in 15.86.0 and 14.99.2.
Affected products
- frappe: before 14.99.2; from 15.0.0 before 15.86.0 — fixed in 14.99.2, 15.86.0
How to fix
Upgrade to a fixed version: frappe 14.99.2, 15.86.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/commit/984c641bff9539b6126a01146096f133db6a955b
- https://github.com/frappe/frappe/security/advisories/GHSA-mp93-8vxr-hqq9
Get alerted when CVE-2025-66205 or the next vulnerability affects your stack