What’s Vulnerable › Vulnerabilities
CVE-2025-66206: Frappe vulnerable to a path traversal allowing reading certain files
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-01 · updated 2026-10-19
- Weakness: CWE-22
Description
Frappe is a full-stack web application framework. Prior to 15.86.0 and 14.99.2, certain requests were vulnerable to path traversal attacks, wherein some files from the server could be retrieved if the full path was known. Sites hosted on Frappe Cloud, and even other setups that are behind a reverse proxy like NGINX are unaffected. This would mainly affect someone directly using werkzeug/gunicorn. In those cases, either an upgrade or changing the setup to use a reverse proxy is recommended. This vulnerability is fixed in 15.86.0 and 14.99.2.
Affected products
- frappe: before 14.99.2; from 15.0.0 before 15.86.0 — fixed in 14.99.2, 15.86.0
How to fix
Upgrade to a fixed version: frappe 14.99.2, 15.86.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66206 or the next vulnerability affects your stack