What’s Vulnerable › Vulnerabilities
CVE-2025-66211: Coolify Vulnerable to Authenticated Remote Code Execution via Command Injection in PostgreSQL Init Script Filename
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-23 · updated 2026-10-19
- Weakness: CWE-78
Description
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. Prior to version 4.0.0-beta.451, an authenticated command injection vulnerability in PostgreSQL Init Script Filename handling allows users with application/service management permissions to execute arbitrary commands as root on managed servers. PostgreSQL initialization script filenames are passed to shell commands without proper validation, enabling full remote code execution. Version 4.0.0-beta.451 fixes the issue.
Affected products
- coollabsio coolify: before 4.0.0; 4.0.0-beta100, 4.0.0-beta101, 4.0.0-beta102, 4.0.0-beta103, 4.0.0-beta104, 4.0.0-beta105 (+434) — fixed in 4.0.0
How to fix
Upgrade to a fixed version: coollabsio coolify 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/0xrakan/coolify-cve-2025-66209-66213
- https://github.com/coollabsio/coolify/pull/7375
- https://github.com/coollabsio/coolify/releases/tag/v4.0.0-beta.451
- https://github.com/coollabsio/coolify/security/advisories/GHSA-24mp-fc9q-c884
- https://github.com/coollabsio/coolify/security/advisories/GHSA-24mp-fc9q-c884
Get alerted when CVE-2025-66211 or the next vulnerability affects your stack