What’s Vulnerable › Vulnerabilities
CVE-2025-66216: AIS-catcher has a Buffer Overflow vulnerability in `AIS::Message` leading to DoS/RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-11-29 · updated 2026-10-07
- Weakness: CWE-131
Description
AIS-catcher is a multi-platform AIS receiver. Prior to version 0.64, a heap buffer overflow vulnerability has been identified in the AIS::Message class of AIS-catcher. This vulnerability allows an attacker to write approximately 1KB of arbitrary data into a 128-byte buffer. This issue has been patched in version 0.64.
Affected products
- jvde-github AIS-catcher: before 0.64 — fixed in 0.64
How to fix
Upgrade to a fixed version: jvde-github AIS-catcher 0.64. Check the vendor advisory for mitigations.
References
- https://github.com/jvde-github/AIS-catcher/commit/3de0ef785fc3c96265a71b37df7b0a82cb279312
- https://github.com/jvde-github/AIS-catcher/security/advisories/GHSA-v53x-f5hh-g2g6
- https://github.com/jvde-github/AIS-catcher/security/advisories/GHSA-v53x-f5hh-g2g6
Get alerted when CVE-2025-66216 or the next vulnerability affects your stack