What’s Vulnerable › Vulnerabilities
CVE-2025-66273: QTS, QuTS hero
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-10 · updated 2026-07-23
- Weakness: CWE-78
Description
A command injection vulnerability has been reported to affect several QNAP operating system versions. If a remote attacker gains an administrator account, they can then exploit the vulnerability to execute arbitrary commands. We have already fixed the vulnerability in the following versions: QTS 5.2.9.3410 build 20260214 and later QuTS hero h5.2.9.3410 build 20260214 and later QuTS hero h5.3.4.3500 build 20260520 and later QuTS hero h6.0.0.3397 build 20260206 and later
Affected products
- QNAP QTS: from 5.2.0.2737 before 5.2.9.3410 — fixed in 5.2.9.3410
- QNAP Systems Inc. QuTS hero: from h5.2.0.2737 before h5.2.9.3410; from h5.3.0.3115 before h5.3.4.3500; from h6.0.0.3324 before h6.0.0.3397 — fixed in h5.2.9.3410, h5.3.4.3500, h6.0.0.3397
How to fix
Upgrade to a fixed version: QNAP QTS 5.2.9.3410; QNAP Systems Inc. QuTS hero h5.2.9.3410, h5.3.4.3500, h6.0.0.3397. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-66273 or the next vulnerability affects your stack