What’s Vulnerable › Vulnerabilities
CVE-2025-66287: Webkitgtk: processing maliciously crafted web content may lead to an unexpected process crash
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-04 · updated 2026-09-25
- Weakness: CWE-120
Description
A flaw was found in WebKitGTK. Processing malicious web content can cause an unexpected process crash due to improper memory handling.
Affected products
- Red Hat Enterprise Linux 7: all versions
- Red Hat Enterprise Linux 7 Extended Lifecycle Support: all versions — fixed in 0:2.50.3-2.el7_9
- Red Hat Enterprise Linux 8: all versions — fixed in 0:2.50.3-1.el8_10
- Red Hat Enterprise Linux 8.2 Advanced Update Support: all versions — fixed in 0:2.50.3-2.el8_2
- Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support: all versions — fixed in 0:2.50.3-2.el8_4
- Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On: all versions — fixed in 0:2.50.3-2.el8_4
- Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support: all versions — fixed in 0:2.50.3-2.el8_6
- Red Hat Enterprise Linux 8.6 Telecommunications Update Service: all versions — fixed in 0:2.50.3-2.el8_6
- Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions: all versions — fixed in 0:2.50.3-2.el8_6
- Red Hat Enterprise Linux 8.8 Telecommunications Update Service: all versions — fixed in 0:2.50.3-2.el8_8
- Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions: all versions — fixed in 0:2.50.3-2.el8_8
- Red Hat Enterprise Linux 9: all versions — fixed in 0:2.50.3-1.el9_7
- Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions: all versions — fixed in 0:2.50.3-1.el9_0
- Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions: all versions — fixed in 0:2.50.3-1.el9_2
- Red Hat Enterprise Linux 9.4 Extended Update Support: all versions — fixed in 0:2.50.3-1.el9_4
- Red Hat Enterprise Linux 9.6 Extended Update Support: all versions — fixed in 0:2.50.3-1.el9_6
- The WebKitGTK Team webkitgtk: before 2.50.3 — fixed in 2.50.3
How to fix
Upgrade to a fixed version: Red Hat Enterprise Linux 7 Extended Lifecycle Support 0:2.50.3-2.el7_9; Red Hat Enterprise Linux 8 0:2.50.3-1.el8_10; Red Hat Enterprise Linux 8.2 Advanced Update Support 0:2.50.3-2.el8_2; Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 0:2.50.3-2.el8_4; Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On 0:2.50.3-2.el8_4; Red Hat Enterprise Linux 8.6 Advanced Mission Critical Update Support 0:2.50.3-2.el8_6; Red Hat Enterprise Linux 8.6 Telecommunications Update Service 0:2.50.3-2.el8_6; Red Hat Enterprise Linux 8.6 Update Services for SAP Solutions 0:2.50.3-2.el8_6; Red Hat Enterprise Linux 8.8 Telecommunications Update Service 0:2.50.3-2.el8_8; Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions 0:2.50.3-2.el8_8; Red Hat Enterprise Linux 9 0:2.50.3-1.el9_7; Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions 0:2.50.3-1.el9_0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2025:22789
- https://access.redhat.com/errata/RHSA-2025:22790
- https://access.redhat.com/errata/RHSA-2025:23110
- https://access.redhat.com/errata/RHSA-2025:23433
- https://access.redhat.com/errata/RHSA-2025:23434
- https://access.redhat.com/errata/RHSA-2025:23451
- https://access.redhat.com/errata/RHSA-2025:23452
- https://access.redhat.com/errata/RHSA-2025:23583
- https://access.redhat.com/errata/RHSA-2025:23591
- https://access.redhat.com/errata/RHSA-2025:23742
- https://access.redhat.com/errata/RHSA-2025:23743
- https://access.redhat.com/security/cve/CVE-2025-66287
Get alerted when CVE-2025-66287 or the next vulnerability affects your stack