What’s Vulnerable › Vulnerabilities
CVE-2025-66294: Grav is vulnerable to RCE via SSTI through Twig Sandbox Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-09-26
- Weakness: CWE-94
Description
Grav is a file-based Web platform. Prior to 1.8.0-beta.27, a Server-Side Template Injection (SSTI) vulnerability exists in Grav that allows authenticated attackers with editor permissions to execute arbitrary commands on the server and, under certain conditions, may also be exploited by unauthenticated attackers. This vulnerability stems from weak regex validation in the cleanDangerousTwig method. This vulnerability is fixed in 1.8.0-beta.27.
Affected products
- getgrav grav: from 1.7.48 before 1.8.0; 1.8.0-beta1, 1.8.0-beta10, 1.8.0-beta11, 1.8.0-beta12, 1.8.0-beta13, 1.8.0-beta14 (+20) — fixed in 1.8.0
How to fix
Upgrade to a fixed version: getgrav grav 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/e37259527d9c1deb6200f8967197a9fa587c6458
- https://github.com/getgrav/grav/security/advisories/GHSA-662m-56v4-3r8f
Get alerted when CVE-2025-66294 or the next vulnerability affects your stack