What’s Vulnerable › Vulnerabilities
CVE-2025-66298: Grav is vulnerable to Server-Side Template Injection (SSTI) via Forms
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-09-26
- Weakness: CWE-1336
Description
Grav is a file-based Web platform. Prior to 1.8.0-beta.27, having a simple form on site can reveal the whole Grav configuration details (including plugin configuration details) by using the correct POST payload to exploit a Server-Side Template (SST) vulnerability. Sensitive information may be contained in the configuration details. This vulnerability is fixed in 1.8.0-beta.27.
Affected products
- getgrav grav: before 1.8.0; 1.8.0-beta1, 1.8.0-beta10, 1.8.0-beta11, 1.8.0-beta12, 1.8.0-beta13, 1.8.0-beta14 (+20) — fixed in 1.8.0
How to fix
Upgrade to a fixed version: getgrav grav 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/e37259527d9c1deb6200f8967197a9fa587c6458
- https://github.com/getgrav/grav/security/advisories/GHSA-8535-hvm8-2hmv
Get alerted when CVE-2025-66298 or the next vulnerability affects your stack