What’s Vulnerable › Vulnerabilities
CVE-2025-66301: Grav ihas Broken Access Control which allows an Editor to modify the page's YAML Frontmatter to alter form processing actions
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-09-26
- Weakness: CWE-285
Description
Grav is a file-based Web platform. Prior to 1.8.0-beta.27, due to improper authorization checks when modifying critical fields on a POST request to /admin/pages/{page_name}, an editor with only permissions to change basic content on the form is now able to change the functioning of the form through modifying the content of the data[_json][header][form] which is the YAML frontmatter which includes the process section which dictates what happens after a user submits the form which include some important actions that could lead to further vulnerabilities. This vulnerability is fixed in 1.8.0-beta.27.
Affected products
- getgrav grav: before 1.8.0; 1.8.0-beta1, 1.8.0-beta10, 1.8.0-beta11, 1.8.0-beta12, 1.8.0-beta13, 1.8.0-beta14 (+20) — fixed in 1.8.0
How to fix
Upgrade to a fixed version: getgrav grav 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-v8x2-fjv7-8hjh
- https://github.com/getgrav/grav/security/advisories/GHSA-v8x2-fjv7-8hjh
Get alerted when CVE-2025-66301 or the next vulnerability affects your stack