What’s Vulnerable › Vulnerabilities
CVE-2025-66302: Grav vulnerable to Path Traversal allowing server files backup
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-09-26
- Weakness: CWE-22
Description
Grav is a file-based Web platform. Prior to 1.8.0-beta.27, A path traversal vulnerability has been identified in Grav CMS, allowing authenticated attackers with administrative privileges to read arbitrary files on the underlying server filesystem. This vulnerability arises due to insufficient input sanitization in the backup tool, where user-supplied paths are not properly restricted, enabling access to files outside the intended webroot directory. The impact of this vulnerability depends on the privileges of the user account running the application. This vulnerability is fixed in 1.8.0-beta.27.
Affected products
- getgrav grav: before 1.8.0; 1.8.0-beta1, 1.8.0-beta10, 1.8.0-beta11, 1.8.0-beta12, 1.8.0-beta13, 1.8.0-beta14 (+20) — fixed in 1.8.0
How to fix
Upgrade to a fixed version: getgrav grav 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/ed640a13143c4177af013cf001969ed2c5e197ee
- https://github.com/getgrav/grav/security/advisories/GHSA-j422-qmxp-hv94
- https://github.com/getgrav/grav/security/advisories/GHSA-j422-qmxp-hv94
Get alerted when CVE-2025-66302 or the next vulnerability affects your stack