What’s Vulnerable › Vulnerabilities
CVE-2025-66303: Grav is vulnerable to a DOS on the admin panel
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-09-26
- Weakness: CWE-400
Description
Grav is a file-based Web platform. Prior to 1.8.0-beta.27, A Denial of Service (DoS) vulnerability has been identified in Grav related to the handling of scheduled_at parameters. Specifically, the application fails to properly sanitize input for cron expressions. By manipulating the scheduled_at parameter with a malicious input, such as a single quote, the application admin panel becomes non-functional, causing significant disruptions to administrative operations. The only way to recover from this issue is to manually access the host server and modify the backup.yaml file to correct the corrupted cron expression. This vulnerability is fixed in 1.8.0-beta.27.
Affected products
- getgrav grav: before 1.8.0; 1.8.0-beta1, 1.8.0-beta10, 1.8.0-beta11, 1.8.0-beta12, 1.8.0-beta13, 1.8.0-beta14 (+20) — fixed in 1.8.0
How to fix
Upgrade to a fixed version: getgrav grav 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/commit/9d11094e4133f059688fad1e00dbe96fb6e3ead7
- https://github.com/getgrav/grav/security/advisories/GHSA-x62q-p736-3997
- https://github.com/getgrav/grav/security/advisories/GHSA-x62q-p736-3997
Get alerted when CVE-2025-66303 or the next vulnerability affects your stack