What’s Vulnerable › Vulnerabilities
CVE-2025-66309: Grav vulnerable to Cross-Site Scripting (XSS) Reflected endpoint /admin/pages/[page], parameter data[header][content][items], located in the "Blog Config" tab
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-06-17
- Weakness: CWE-79
Description
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Reflected Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][content][items] parameter. This vulnerability is fixed in 1.11.0-beta.1.
Affected products
- getgrav grav-plugin-admin: through 1.10.50
References
- https://github.com/getgrav/grav-plugin-admin/commit/99f653296504f1d6408510dd2f6f20a45a26f9b0
- https://github.com/getgrav/grav/security/advisories/GHSA-65mj-f7p4-wggq
- https://github.com/getgrav/grav/security/advisories/GHSA-65mj-f7p4-wggq
Get alerted when CVE-2025-66309 or the next vulnerability affects your stack