What’s Vulnerable › Vulnerabilities
CVE-2025-66312: Grav Admin Plugin vulnerable to Cross-Site Scripting (XSS) Stored endpoint `/admin/accounts/groups/[group]` parameter `data[readableName]`
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-12-01 · updated 2026-09-26
- Weakness: CWE-79
Description
This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/accounts/groups/Grupo endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[readableName] parameter. The injected scripts are stored on the server and executed automatically whenever the affected page is accessed by users, posing a significant security risk. This vulnerability is fixed in 1.11.0-beta.1.
Affected products
- getgrav grav-plugin-admin: through 1.10.50
References
- https://github.com/getgrav/grav-plugin-admin/commit/99f653296504f1d6408510dd2f6f20a45a26f9b0
- https://github.com/getgrav/grav/security/advisories/GHSA-rmw5-f87r-w988
- https://github.com/getgrav/grav/security/advisories/GHSA-rmw5-f87r-w988
Get alerted when CVE-2025-66312 or the next vulnerability affects your stack