What’s Vulnerable › Vulnerabilities
CVE-2025-66385
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-28 · updated 2026-10-19
- Weakness: CWE-472
Description
UsersController::edit in Cerebrate before 1.30 allows an authenticated non-privileged user to escalate their privileges (e.g., obtain a higher role such as admin) via the user-edit endpoint by supplying or modifying role_id or organisation_id fields in the edit request.
Affected products
- cerebrate-project Cerebrate: before 1.30 — fixed in 1.30
How to fix
Upgrade to a fixed version: cerebrate-project Cerebrate 1.30. Check the vendor advisory for mitigations.
References
- https://github.com/cerebrate-project/cerebrate/commit/c9bfa90abc85d4a20a9cc2f282959b72bef829bb
- https://github.com/cerebrate-project/cerebrate/compare/v1.29...v1.30
- https://vulnerability.circl.lu/api/vulnerability/gcve-1-2025-0017
Get alerted when CVE-2025-66385 or the next vulnerability affects your stack